Node.js 教程

安装 npm 包的旧版本

2020-12-03 10:22:01 更新   浏览量: 367
上一章:查看 npm 包安装的版本 下一章:Node.js 依赖包更新到最新版本

安装 npm 包的旧版本

可以使用 @ 语法来安装 npm 软件包的旧版本:

npm install <package>@<version>

示例:

npm install cowsay

以上命令会安装 1.3.1 版本(在撰写本文时)。

使用以下命令可以安装 1.2.0 版本:

npm install cowsay@1.2.0

全局的软件包也可以这样做:

npm install -g webpack@4.16.4

可能还有需要列出软件包所有的以前的版本。 可以使用 npm view <package> versions

❯ npm view cowsay versions

[ '1.0.0',
  '1.0.1',
  '1.0.2',
  '1.0.3',
  '1.1.0',
  '1.1.1',
  '1.1.2',
  '1.1.3',
  '1.1.4',
  '1.1.5',
  '1.1.6',
  '1.1.7',
  '1.1.8',
  '1.1.9',
  '1.2.0',
  '1.2.1',
  '1.3.0',
  '1.3.1' ]
扫二微码
上一章:查看 npm 包安装的版本 下一章:Node.js 依赖包更新到最新版本

最近更新 免责声明 关于我们

Copyright © 2004-2021 前端教程 qianduan.cn All Rights Reserved   陕ICP备2021014585号-1 陕公网安备 61012402000223号 前端教程

友情链接:  前端工具 前端插件 前端小川

Node.js 教程